Forum


Welcome, Guest
Username: Password: Remember me

TOPIC: Breadcrumbs -wirr-warr und 404-Flut

Breadcrumbs -wirr-warr und 404-Flut 4 weeks 1 day ago #6463

  • Florian
  • Florian's Avatar
  • Offline
  • User Rating: 0
Hallo,

wir haben ein Problem mit den Breadcrumbs - Einträge werden entweder doppelt angezeigt oder Links funktionieren nicht.

Unsere Struktur sieht folgendermaßen aus:
Kurse
- Subkategorie
- Subkategorie
- Subkategorie
- ...
Dabei ist jeder Kurs sowohl in "Kurse", sowie in einer oder auch mehreren Subkategorien. Das Menü auf der Seite sieht wie oben abgebildet aus.

Bei den Breadcrumbs funktioniert aber irgendwas nicht:
  • Wenn Komponentenpfad = "Nein", wird der Pfad zwar richtig angezeigt (Home > Kurse > Subkategorie), aber der Kurse-Link generiert einen 404-Fehler
  • Wenn Komponentenpfad = "Anzeige in Breadcrumb-Position" funtioniert der letzte Breadcrumb-Link, dafür sind die Einträge Kurse und Subkategorie und die ersten beiden funktionieren ebenso nicht (Anzeige: Home > Kurse > Subkategorie > Kurse > Subkategorie)

Beim Menü habe ich sowohl die Eintragstypen "Startlayout" und "Kategorie" getestet, ging aber nicht.

Nachdem unsere 404-er Seite aufgrund dieser Thematik bereits mehrere 100 Zugriffe hat, würde ich das Problem gerne lösen.

Sollte es etwas helfen, hier der Link zu unserer Seite:
https://su-neusiedl.at/kurse

Vielen Dank!

Liebe Grüße,
Florian
The administrator has disabled public write access.

Breadcrumbs -wirr-warr und 404-Flut 4 weeks 14 hours ago #6466

  • SigiK
  • Premium Member
  • OSG Support
  • SigiK's Avatar
  • Offline
  • User Rating: 81
Hallo Florian,
1. welche Einstellungen habt ihr unter optionen > misc > SEO (bitte Screenshot machen)

Ein Startlayout darf definitiv nur EINMAL angelegt werden. Habt ihr das beachtet?
Sigrid
Your feedback on the extensions.joomla.org/extensions/extensi.../osg-seminar-manager supports our work and the further development of our products.
The administrator has disabled public write access.

Breadcrumbs -wirr-warr und 404-Flut 4 weeks 2 hours ago #6477

  • Florian
  • Florian's Avatar
  • Offline
  • User Rating: 0
Hallo Sigrid,

Wir haben das Startlayout nur einmal (und das erst später testhalber eingeführt, da ich das Layout anders bevorzuge)

ich habe jetzt sämtliche Kombinationen durchprobiert.

Das einzige, was funktioniert, ist "Schöne URL = Nein" in Kombi mit "Komponenten-Pfade = Nein".
Der Link geht dann zwar auf ".../kurse/1", aber es funktioniert immerhin.
...Dafür wird in der URL jetzt eine Kategorie hinzugefügt, also z.B. /kurse/subkategorie/3-subkategorie/[Kursname]

Sobald ich auf Schöne URL = ja stelle, ist die URL zwar nicht doppelt, dafür gehen die Breadcrumbs nicht mehr.

Liebe Grüße,
Florian
The administrator has disabled public write access.

Breadcrumbs -wirr-warr und 404-Flut 3 weeks 6 days ago #6479

  • SigiK
  • Premium Member
  • OSG Support
  • SigiK's Avatar
  • Offline
  • User Rating: 81
Hmm, ich glaube, ihr habt ein Modul zu Anzeige des Breadcrumbs benutzt?
Teste mal folgendes:
Versteck das Modul und nutze für die Einstellung: Anzeige in Komponentenpfade > Anzeige in Komponente.
Der OSG Seminar Manager generiert dann einen eigenen Breadcrumb.
Eventuell gefällt dir dieser besser.
Sigrid
Your feedback on the extensions.joomla.org/extensions/extensi.../osg-seminar-manager supports our work and the further development of our products.
The administrator has disabled public write access.

Breadcrumbs -wirr-warr und 404-Flut 3 weeks 6 days ago #6480

  • SigiK
  • Premium Member
  • OSG Support
  • SigiK's Avatar
  • Offline
  • User Rating: 81
P.S. für die anderen Seiten könntet ihr auch das Modul weiterhin nutzen.
Aber wir werden das andere dennoch testen, ob du da auf einen Bug gestoßen bist.
Sigrid
Your feedback on the extensions.joomla.org/extensions/extensi.../osg-seminar-manager supports our work and the further development of our products.
The administrator has disabled public write access.

Breadcrumbs -wirr-warr und 404-Flut 2 weeks 3 days ago #6506

  • Florian
  • Florian's Avatar
  • Offline
  • User Rating: 0
Hallo Sigrid,

ja, wir haben das Breadcrumb-Modul aktiviert.
die Einstellung "in Komponente anzeigen geht natürlich", aber dabei wird
a) die Homepage nicht verlinkt
b) das Aussehen ist anders

Ich habe nun auch verschiedenste Varianten mit Verstecken des Breadcrumb-Moduls auf den Kursseiten probiert - keine funktioniert.
Daher habe ich jetzt die SEO-URL (so schön sie auch ist) deaktiviert.
Vielleicht könnt ihr das Problem beheben.

Liebe Grüße,
Florian
The administrator has disabled public write access.
© 2017 Open Source Groupe GmbH Alle Rechte vorbehalten.
Cookies make it easier for us to provide you with our services. With the usage of our services you permit us to use cookies.
More information Ok